[Development] Spelling of module names in documentation
andre.poenitz at nokia.com
Wed Dec 14 10:54:13 CET 2011
On Wednesday 14 December 2011 10:34:54 ext henry.haverinen at nokia.com wrote:
> Hi all,
> I got some feedback outside this list about the documentation spelling of module names that contain acronyms. Now the guideline says we should write about the Qt Sql module, the Qt Xml module and so on. The feedback is that we should write about the Qt SQL module, the Qt XML module, the Qt XML Patterns module, the Qt MIME Types module and so on. The short version used in the code would continue be QtSql, QtXml and so on.
> I agree this would lead to more natural language in documentation and other communications, so I propose we change the guideline in the wiki accordingly.
> Kevin and others, any comments?
> > -----Original Message-----
> > From: development-bounces+henry.haverinen=nokia.com at qt-project.org
> > [mailto:development-bounces+henry.haverinen=nokia.com at qt-
> > project.org] On Behalf Of Haverinen Henry (Nokia-MP-Qt/Tampere)
> > Sent: Friday, December 09, 2011 10:01 AM
> > To: Wright Kevin (Nokia-MP-Qt/Oslo); development at qt-project.org
> > Subject: [Development] Spelling of module names in documentation
> > Hi all,
> > The documentation is currently using various spelling styles for module
> > names, so I've worked with our technical writers and Kevin (the
> > documentation maintainer) on this wiki article:
> > http://developer.qt.nokia.com/wiki/Spelling_Module_Names_in_Qt_Docu
> > mentatio
> > n
> > Comments?
> > There are a couple of special cases that may need some further discussion:
> > - Qt Publish Subscribe: should we drop the "and" to make the documentation
> > and code consistent
> > - Qt System Info instead of Qt System Information to make the
> > documentation and code consistent
> > - ActiveQt
> > - Qt WebKit for WebKit 1 stuff - should that potential module be called Qt
> > WebKit Widgets, similarly to Qt Multimedia Widgets? That could still cover Qt
> > Quick 1 based stuff, because QDeclarativeView is a widget...
I don't have a strong opinion on the docs. I'd think all caps is ok there
if the items in question are known under such a name.
But note that the class names are supposed to use QXml*
(...StreamReader e.g.), QFtp* etc.
More information about the Development