[Development] api changes
samuel.rodal at nokia.com
Fri Apr 13 20:42:26 CEST 2012
On 04/13/2012 08:41 PM, ext Girish Ramakrishnan wrote:
> On Fri, Apr 13, 2012 at 11:30 AM, Girish Ramakrishnan
> <girish at forwardbias.in> wrote:
>> I think the idea with _qpa_ in the file name is to imply that it has
>> plugin api. As opposed to let's say qpen_p.h. This means that when I
>> see a change to a _qpa.h file, I know that plugins will get affected
>> by this api change. However, this fact can already be deduced from the
>> qplatform prefix. The only exceptions, I see are:
>> 1. qwindowsysteminterface, which can be renamed at some point to be
The _qpa in the file name was just the equivalent of _mac, _win, _x11,
and _qws in Qt 4.x days.
> Scratch that. QWindowSystemInterface is meant to be public api, I think.
Well, it's used by generic plugins, and maybe also in testlib etc for
simulating mouse clicks. It's also different from the QPlatform* classes
in that it's not going to be sub-classed in the platform plugins.
More information about the Development