[Development] important: upcoming rename of _qpa.h to _p.h
Paul Olav Tvete
paul.tvete at nokia.com
Tue Apr 17 10:34:33 CEST 2012
On Tuesday 17 April 2012 03:57:16 ext Girish Ramakrishnan wrote:
> As per the previous discuss, I renamed all the _qpa.h to _p.h with a
> couple of helper scripts
I just added the following "-1" comment on gerrit:
I do not agree with this change. We have made a difference between public API
and plugin API, and this is different from private implementation detail.
The rest of the Lighthouse team are also skeptical. The main issue, as far as I
can see, is documentation. This can be solved much in a much simpler way by
using the \internal tag, as discussed earlier. There should also be a warning in
the _qpa.h files, but it shouldn't be the "don't even think of using this file"
warning from the _p.h file; these files are there for platform plugin authors
More information about the Development