[Development] fixing name of QNetworkAccessManager::createRequest
rich at kde.org
Sun Jan 15 17:08:16 CET 2012
On Sun, Jan 15, 2012 at 2:25 PM, Peter Kümmel <syntheticpp at gmx.net> wrote:
> But to think first about what "createRequest" really does is a good idea:
> It not only creates a request, it also sends it, so why not rename it to
> 'doRequest' or something similar which is different to 'createReply'
> which is as misleading as 'createRequest'.
> A new name would stop the compiler and there will be no silent bugs.
> And replacing a simple function name isn't that hard, so there is no
> need for a 'migration path' via deprecated functions.
There would still be silent errors for people who have reimplemented
the createRequest method (it's virtual). I think this was covered
earlier in this thread.
More information about the Development