[Qt-creator] Planning Qt Creator 2.8 + 0.1

Ziller Eike Eike.Ziller at digia.com
Fri Jun 14 08:57:10 CEST 2013


On 13.06.2013, at 17:35, Teske Daniel <Daniel.Teske at digia.com>
 wrote:

> Some important detail is, that Andre and me just realized:
> clang only supports c++11 with libc++.
> libc++ is only supported from 10.7.
> 10.6 is still widely used and we can't realistically drop support for that this year.
> 
> Unless I'm mistaken, that stops us from using c++11 any time soon…

To clarify this a bit:
Using c++11 / libc++ in Qt Creator would mean that we need to drop support for *compiling* Qt Creator on Mac OS X 10.6 (afair clang isn't easily available on 10.6 anyhow)
But as far as I know, it is possible to package libc++ (and libc++abi which is needed by that) together with Qt into Qt Creator builds, and deploy on 10.6.
I can double-check if this is indeed true.

So, how important would *compiling* Qt Creator on 10.6 be, if it was still possible to deploy and run Qt Creator on 10.6 ?

-- 
Eike Ziller, Senior Software Engineer - Digia, Qt
 
Digia Germany GmbH, Rudower Chaussee 13, D-12489 Berlin
Geschäftsführer: Mika Pälsi, Juha Varelius, Anja Wasenius
Sitz der Gesellschaft: Berlin, Registergericht: Amtsgericht Charlottenburg, HRB 144331 B



More information about the Qt-creator mailing list