[Qt-creator] Android "this does not seem to be a debug build"

Jason H scorp1us at yahoo.com
Wed Feb 19 15:04:29 CET 2014


But this isn't a release build.

Under the little android guy it says "debug" and two buttons below, with the blue bug over the play icon is what I am clicking on. Hence my issue.

Why would it not be a debug build?


________________________________
 From: BogDan <bog_dan_ro at yahoo.com>
To: Jason H <scorp1us at yahoo.com>; "qt-creator at qt-project.org" <qt-creator at qt-project.org> 
Sent: Wednesday, February 19, 2014 2:17 AM
Subject: Re: [Qt-creator] Android "this does not seem to be a debug build"
 

Hi,


  You need to uncheck *Warn when debugging “Release” builds*.
Check: http://www.kdab.com/qt-on-android-episode-2/

Cheers,
BogDan.



>
>I know it is a debug build, but it says the following sections are not found:
>.debug_info
>.debug_abbrev
>.debug_line
>.debug_str 
>.debug_loc 
>.debug_range
>.gdb_index 
>.note.gnu.build-id
>.gnu.hash  
>.gnu_debuglink
>
>
>QtCreator built the binary when I clocked on the debug icon. I tried 2 devices.
>
>
>Any ideas?
>
>
>_______________________________________________
>Qt-creator mailing list
>Qt-creator at qt-project.org
>http://lists.qt-project.org/mailman/listinfo/qt-creator
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.qt-project.org/pipermail/qt-creator/attachments/20140219/e496f8f0/attachment.html 


More information about the Qt-creator mailing list