[Qt-creator] ClangCodeModel.dll could not be found

Ziller Eike Eike.Ziller at digia.com
Fri Sep 19 07:40:31 CEST 2014


On Sep 18, 2014, at 10:25 PM, Pawel <pawelfaron87 at wp.pl> wrote:

> Hello,
> 
> I'm trying to build QtCreator 3.2.1 with Clang support using Visual Studio  
> 2013 for 64 bit.
> So I set the LLVM_INSTALL_DIR variable to Clang path before 'qmake -r' and  
> everything goes fine.
> But when I'm running QtCreator I have this error:
> 
> "G:\qt-creator-opensource-src-3.2.1\lib\qtcreator\plugins\ClangCodeModel.dll:  
> Cannot load library  
> G:/qt-creator-opensource-src-3.2.1/lib/qtcreator/plugins/ClangCodeModel.dll:  
> The specified module could not be found."
> 
> Even though the 'ClangCodeModel.dll' is in the specified directory.
> Does anyone have this problem? I've tried on 2 computers with Windows 7  
> and Windows 8.

If I remember the details correctly, on windows the *runtime* linker searches for dlls in
* the directory with the exe
* the path
* system directories
(in whatever order)

You have to either copy the libclang dll (the one from llvm) into Qt Creator’s bin directory, or run within an environment that includes a PATH to where it lies.

Br, Eike

-- 
Eike Ziller, Senior Software Engineer - Digia, Qt
Digia Germany GmbH, Rudower Chaussee 13, D-12489 Berlin
Geschäftsführer: Mika Pälsi, Juha Varelius, Anja Wasenius
Sitz der Gesellschaft: Berlin. Registergericht: Amtsgericht Charlottenburg, HRB 144331 B 



More information about the Qt-creator mailing list