[Development] Changing the return type of QMetaMethod::signature()

Olivier Goffart olivier at woboq.com
Thu Feb 23 22:58:24 CET 2012


On Thursday 23 February 2012 18:36:22 Marc Mutz wrote:
> On Wednesday February 15 2012, Kent Hansen wrote:
> > However, if some code does do
> > 
> > const char *sig = myMethod.signature();
> > // do something with sig (call strlen et al) ...
> 
> ...it will generate a deprecated warning under
> http://codereview.qt-project.org/17343, or fail to compile under
> QT_NO_DEPRECATED/QT_NO_CAST_FROM_BYTEARRAY, so I don't see a big problem
> with changing the return type.

What we eventualy decided to do is to change the name of the method to 
QMetaMethod::methodSignature().  This name is consistant with the other 
function in that class.

--->  http://codereview.qt-project.org/#change,17347

(Notice the nice error you get on code that used signature())

-- 
Olivier




More information about the Development mailing list