[Development] qtwayland module fails to build for Raspberry Pi

Jon Trulson jon at radscan.com
Thu Oct 18 18:06:30 CEST 2012

On Tue, 16 Oct 2012, Thiago Macieira wrote:

> On terça-feira, 16 de outubro de 2012 15.25.40, Jon Trulson wrote:
>> However, compiling qtwayland fails with many errors - errors that
>> imply qtwayland cannot work with the wayland installed on the rpi.
> Probably. Upgrade your Wayland to 0.95 at least.

Ok, I tried this - got wayland itself to build, but qtwayland fails
compiling compositor_api/waylandsurfaceitem.cpp:

compositor_api/waylandsurfaceitem.cpp:55:32: fatal error:
QtQuick/QQuickCanvas: No such file or directory

I believe this header was depricated some time ago?

I will try the SHA1 mentioned in emails below - but IIRC when I tried
that originally, it too failed due to changes made in
waylandresourcecollection.cpp and waylandresourcecollection.h in later
qtwayland commits.

I will try this again right now though - maybe I missed something, it
was a long night :)

Jon Trulson

The Higgs Field is what make atoms matter.
                 -- Tom L.

More information about the Development mailing list