[Development] Failure in tst_qwidget

Alberto Mardegan mardy at users.sourceforge.net
Sat Mar 2 08:45:28 CET 2013

Hi all!
  The CI bot reported a failure in tst_qwidget when merging
(see the last comment from "Qt Continuous Integration System").

I can reproduce the same failure under ubuntu 13.04 running XFCE.
Then I removed my patch (by checking out an older version of the dev
branch, c65ecc50ae4c322294f01685a2b2d2a748a9c940), and ran "make clean"
from the qtbase root directory.
After having rebuild everything (by just running "make"), I tried
running the tst_qwidget again, but I still get the same failure.

Interestingly, the failure does not occur if I run the individual test
which is failing (both with my patch and without):

tests/auto/widgets/kernel/qwidget$ ./tst_qwidget showHideShowX11
********* Start testing of tst_QWidget *********
Config: Using QTest library 5.1.0, Qt 5.1.0
PASS   : tst_QWidget::initTestCase()
PASS   : tst_QWidget::showHideShowX11()
PASS   : tst_QWidget::cleanupTestCase()
Totals: 3 passed, 0 failed, 0 skipped
********* Finished testing of tst_QWidget *********

So, I wonder:
1) Did I take to correct steps to rebuild qtbase?
2) Did someone else experience this failure as well? Or is it definitely
related to my patch?
3) Any idea why the individual test works? Could it be a WM timing issue?


http://blog.mardy.it <- geek in un lingua international!

More information about the Development mailing list