[Development] CI Network Server Problems

Richard Moore rich at kde.org
Tue Mar 5 22:09:53 CET 2013

I was asked to look into the CI failures caused by the QSslSocket
tests (QTBUG-29941), but unfortunately doing so has shown we have a
wider problem. My old network test server was no longer working
(probably due to the move from nokia to digia) so I tried so setup a
new one and it turns out that the instructions for doing so do not
work currently (QTQAINFRA-601). I've tried setting up a test server
with two different versions of ubuntu (the documented one, and the
latest LTS version) but neither works. This makes it impossible for me
to help address the CI failures.

Looking at the current network test server setup I can see that it
doesn't have the infrastructure required to perform the test that was
failing in the bug that was assigned to me, though it should be easy
enough to add. I can generate the required certs, and can even write
the required apache config, but I have no clue about the puppet side
of things. We need a process for developers to get this sort of issue
addressed, simply file a bug against QTQTINFRA?

At the moment, addressing QTBUG-29941 is completely stalled. I'll try
a 3rd time with ubuntu 11.10 (which isn't an LTS release) this
weekend, but this is getting rather tiresome.

There is a wider need to refactor the network tests, but that's not
something that I can look at in the time available to me.



More information about the Development mailing list