[Development] File Selectors API, still for 5.1?

Alan Alpert 416365416c at gmail.com
Tue Mar 26 21:43:36 CET 2013

On Tue, Mar 26, 2013 at 11:04 AM, Thiago Macieira
<thiago.macieira at intel.com> wrote:
> On segunda-feira, 25 de março de 2013 10.42.27, Alan Alpert wrote:
>> > This is not good enough a reason. Any new feature can only be accepted in
>> > *dev* once it's complete: that is, it is there, works, unit-tested,
>> > documented, with examples if necessary, and an initial API review has been
>> > done. If your feature is still discussing the class name, it indicates
>> > that
>> > the initial API review is not concluded.
>> I got the impression that the initial API review was done. Then
>> someone brought up that they didn't like the name...
> Ok, that sounds more like nitpicking. We can always rename a class before it's
> released. That doesn't stop the integration, though, if everything else is
> fine.
> Unfortunately, the rest of the email thread doesn't lead me to believe that it
> is.
>> >> 2) What to call it?
>> >> Oswald suggested "QPathSelector. or QPathSwitch[er]. or
>> >> QPathMultiplexer."  I'm still leaning towards QFileSelectors, but I'd
>> >> also be happy with Q[File|Path]Switcher or QPathMultiplexer. I know
>> >> that everyone has an opinion on naming matters, is there something
>> >> even better that we haven't thought of yet?
>> >
>> > Explain here in a few words what the class is meant to do and how it does
>> > that. That's two things I'm asking for: what and how. The name should come
>> > from one or both.
>> Applies selectors to file paths. Hence QFileSelectors (QPathSelectors
>> maybe).
> What is a selector? Maybe I should just read the documentation...
> "    QFileSelectors provides a convenient way of selecting file variants based
> on platform or device characteristics."
> (BTW, the docs are missing the \brief)
> "Multiplexer" is too complex a term. "Switcher" gives the impression that you
> can switch it -- as in switching from Android to iOS to QNX. That doesn't look
> right to me. So "Selector" is better -- singular since it's what the class
> does, not that it applies "selectors" to the name.

Okay, maybe I'm too close to the issue. I'll rename it QFileSelector
(and add the \brief).

Alan Alpert

More information about the Development mailing list