[Development] Adding support for version number comparisons

Keith Gardner kreios4004 at gmail.com
Mon Jun 2 15:12:58 CEST 2014

On Mon, Jun 2, 2014 at 7:33 AM, Jake Petroules <jake.petroules at petroules.com
> wrote:

> On 2014-06-02, at 08:24 AM, Richard Moore <rich at kde.org> wrote:
> On 2 June 2014 13:12, Keith Gardner <kreios4004 at gmail.com> wrote:
>> On Mon, Jun 2, 2014 at 2:36 AM, Simon Hausmann <simon.hausmann at digia.com>
>> wrote:
>>> I suggest a name that is more centric towards the _function_ of the
>>> class,
>>> comparison of different software versions.
>> QVersionInformation was also proposed as a name in the code review.  I
>> don't have a problem with changing the name other than it is really long
>> for a simple class.
> How about QVersionComparator?
> QVersionComparator sounds like something you'd pass to a QVersion in order
> to customize the comparison algorithm. QVersion is an object which
> represents a version; comparison is an auxiliary function to its identity.

I agree with Jake.  The class is a container first and then it has
comparison operators.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20140602/3613f7dd/attachment.html>

More information about the Development mailing list