[Development] Qt WebSockets

Gladhorn Frederik Frederik.Gladhorn at digia.com
Fri May 2 12:43:23 CEST 2014

On 01 May 2014, at 22:31, Steve Gold <steveg2357 at gmail.com<mailto:steveg2357 at gmail.com>> wrote:

I just tried to run the echo client and server examples using qt-opensource-windows-x86-android-5.3.0-RC_2014-04-29_22-03-28-79.exe<http://download.qt-project.org/snapshots/qt/5.3/5.3.0-RC/2014-04-29_79/qt-opensource-windows-x86-android-5.3.0-RC_2014-04-29_22-03-28-79.exe> and MinGW on Windows 8 64 bit from Qt Creator. The server displays
QIODevice::read: device not open
QIODevice::read: device not open
SSL Echo Server listening on port 1234
when it runs but the client has a blank window and “Websocket connected” is never shown.

It looks like there may be a problem here.

Have you tried on a real device?
We got the echo client/server both running on devices. Usually android devices ship openSSL in some form, but the simulator doesn’t as far as I know.

So you’ll have to provide a build of openSSL most likely.

In general try if you get any other SSL connection to work.


Development mailing list
Development at qt-project.org<mailto:Development at qt-project.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20140502/5139c6ed/attachment.html>

More information about the Development mailing list