[Development] wec2013 build fails with qt 5.6 beta in dbus.

Gunnar Roth gunnar.roth at gmx.de
Mon Dec 21 21:58:46 CET 2015

Hi Thiago,
> Am 21.12.2015 um 19:46 schrieb Thiago Macieira <thiago.macieira at intel.com>:
> On Monday 21 December 2015 17:44:19 Gunnar Roth wrote:
>> Hi,
>> the problem is that dbus is set to runtime instead of no for windows from
>> configure when no dbus support is found. So it is being tried to build it,
>> which fails, mostly due to using 'interface' as identifier, which seems to
>> be a define somewhere in the wec2013 headers. I wil add -no-dbus to my
>> configure line. 
>> I assume there is no ci in place for wec2013?
> There is and it probably has -no-dbus.

How am I supposed know? It worked without that since 5.2.1.  How should anybody know that now -no-dbus is needed. Why has configure app.cpp so many special cases for ce, which disable ssl even if you give -openssl to configure ( fixed in dev) or disable sse(2) for ce, even if you give -sse2 to configure, which is a use case when having an x86 wec2013? But there is no bus disabling, which would actually make sense and the other before mentioned cases do not.


More information about the Development mailing list