[Development] Deprecating modules with 5.5

Jan Kundr√°t jkt at kde.org
Tue Mar 17 17:14:38 CET 2015


On Tuesday, 3 February 2015 08:33:46 CET, Knoll Lars wrote:
> * Qt WebKit

While I understand the reasons on why you want to remove this one, I think 
that this goes against the promise of compatibility at [1]:

"Qt essentials define the foundation of Qt on all platforms. They are 
available on all supported development platforms and on the tested target 
platforms. They will remain source and binary compatible during Qt 5."

Both "Qt WebKit" and "Qt WebKit Widgets" are listed under Essentials. 
QtScript and QtDeclarative are listed as Addons, and "could probably go".

You're of course free to do whatever you want to do -- it's just that the 
project has promised that this won't happen.

Cheers,
Jan

[1] http://doc.qt.io/qt-5/qtmodules.html

-- 
Trojit√°, a fast Qt IMAP e-mail client -- http://trojita.flaska.net/



More information about the Development mailing list