[Development] qtwebkit

Harald Vistnes harald.vistnes at gmail.com
Fri Dec 16 09:55:06 CET 2016


is it still possible to build the qtwebkit module manually in 5.8.0? I've
tried fetching the sources from git, but qtwebkit is not built. I guess I
have to change some build scripts since it is obsolete, but I am not sure
what needs to be done.

Here is what I did

git clone git://code.qt.io/qt/qt5.git
cd qt5
perl init-repository
git checkout 5.8.0
configure -prefix %CD%\qtbase -opensource -shared -confirm-license
-debug-and-release -release -opengl desktop -qt-zlib -qt-libpng -no-angle
-qt-libjpeg -icu -skip qtconnectivity -skip qtlocation -skip qtsensors
-skip qtwayland -skip qtserialbus -skip qtserialport -skip
qtvirtualkeyboard -skip qtdatavis3d -skip qtcharts -skip qtpurchasing -skip
qtspeech -skip qtnetworkauth -skip qtwebengine -platform win32-msvc2015
-nomake tests

I tried removing qtwebkit from QT_SKIP_MODULES in qt.pro (line 29), but
that did not help.

I'm on Windows 10 with VS2015. I've built qtwebkit before, so I think I
have all dependencies installed.

What am I missing?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20161216/5bdbf92f/attachment.html>

More information about the Development mailing list