[Development] RFC: lambda or lambda return from lambda?
Christian Kandeler
christian.kandeler at theqtcompany.com
Mon Feb 1 14:16:57 CET 2016
On 02/01/2016 03:10 PM, Marc Mutz wrote:
> The point of giving names to things (variable, functions, classes) in
> programming is so you don't need to look at the implementation all the time to
> see what it's doing. You only need to look when you want to see _how_ it's
> doing what it does.
>
> So if you think that this is not a problem, then it's not a problem for you,
> either, if local variables are named only a, b, c, ...
Depending on the context, yes. For instance, I have never written this:
for (int thisIsACounterThatIsUsedForIteration = 0;
thisIsACounterThatIsUsedForIteration < arrayLen;
++thisIsACounterThatIsUsedForIteration) { ... }
Instead, I simply use the name "i". Inacceptable?
Christian
More information about the Development
mailing list