[Development] Qt 5.6.0 (final) packages available

Jan Kundr√°t jkt at kde.org
Mon Mar 14 20:36:57 CET 2016


> That's kded/kiod, not Plasma.

Yes; however, given that kded is used in a default configuration of Plasma 
5, the end result is that the Plasma panel (and krunner, and possibly other 
components) "won't work" with the current version of Qt 5.6.

> And I am reacting to the bug reports.

It wasn't my intention to judge your responsiveness in any way, sorry that 
it sounded that way. In fact, I appreciate your swift feedback that you 
gave me on the relevant bug reports despite your current workload -- thanks 
a lot!

> I just don't have the time to analyse the issue and verify whether the 
> solution proposed is the correct one. And since we're talking about QtDBus 
> here, there aren't other people to help. So either we release 
> this now or we 
> wait until mid-April, when I can get back to developing code.

Understood. What about option three -- applying that patch and 
investigating later. I understand that there's a risk that it includes 
other unknown failures to applications other than kded/kiod; however, I 
think that "KDE works, there may be some failures elsewhere" is a better 
outcome than "KDE definitely doesn't work, there may be other failures 
elsewhere". Other people might see it differently, my two cents is that 
I've been running my Plasma5 desktop with this patch for a few days, and it 
works.

But anyway, I just wanted to respond to a call for known regressions; it's 
up to the Qt project to evaluate possible impact of various possible 
actions and determine its priorities here. I don't have much of a horse in 
this race, really.

Cheers,
Jan

-- 
Trojit√°, a fast Qt IMAP e-mail client -- http://trojita.flaska.net/



More information about the Development mailing list