[Development] Cloning version 5.6.2

Edward Welbourne edward.welbourne at qt.io
Tue Jan 10 13:03:47 CET 2017

Daniel Pfeifer wrote:
> Up until one month ago, the following worked to clone version 5.6.2:
> git clone --branch v5.6.2 git://code.qt.io/qt/qt5.git .
> ./init-repository --module-subset=essential,qtconnectivity,qtlocation,qtserialbus,qtserialport
> It now fails with the following output:
> + git clone --branch 5.6.2 git://code.qt.io/qt/qtbase.git qtbase
> Cloning into 'qtbase'...
> fatal: Remote branch 5.6.2 not found in upstream origin

That is because the M.m.p branch is always transient and goes away when
the vM.m.p tag gets set; so the branch is gone.

> If I pass `--branch v5.6.2` to `init-repository`, I get the same error.

v5.6.2 is a tag, not a branch.
The branch was 5.6.2

> How can I get the exact tagged version v5.6.2?

git clone without specifying --branch (or with any branch you like, it
doesn't matter) then

git checkout v5.6.2


More information about the Development mailing list