[Development] QList

Scott Aron Bloom scott at towel42.com
Mon Mar 27 21:19:38 CEST 2017


-----Original Message-----
From: Development [mailto:development-bounces+scott=towel42.com at qt-project.org] On Behalf Of Giuseppe D'Angelo
Sent: Monday, March 27, 2017 12:09
To: André Pönitz <apoenitz at t-online.de>
Cc: development at qt-project.org
Subject: Re: [Development] QList

Il 27/03/2017 21:03, André Pönitz ha scritto:
>>> vector<point> is an ordered collection of points, but a QVector can 
>>> contain anything; QVector<void*> can even contain unlike things, 
>>> which is truly a tuple. So the problem here is the name QVector. The 
>>> basic collection should be called QTuple or QArray, and QVector 
>>> should mean QTuple<QPoint>.
>> As Marc already told you, the problem here is that there's already 
>> 20+ years of experience in the C++ community with the name "vector"
>> indicating a very precise thing (which has nothing to do with 
>> geometry or linear spaces).
> Since when is $SOME_COMMUNITY_WE_ARE_INTERESTED_IN is using $FEATURE 
> since $ETERNITY a valid argument in this thread here?

When people started doing claims about "how things should be named (and why)" (which, yes, itself was an unnecessary thread derailment. But I didn't start *that*.)

Cheers,
=========

My two bits, as a 15+ year Qt professional level user, and semi-active qt-list person, who is on this list to see whats going on, but doesn’t have much time to actively develop... Sometimes called a whiner 😊

Calling it a "List" is wrong...it does imply linked list... If you wanted to have two "vectors" of different levels of optimization, QArray and QVector would have been my preference.

As somone who lived through the Qt 3->4 pain, (and who as a consultant helped 30+ projects do the conversion), it was painful.  But not because of the naming, mostly because of lost functionality that didn’t exist until Graphics View came back  To be honest, I forget which "view" Qt3 used that had to wait until Qt4's QGraphicsView was of full quality.

Also, the major change was converting all of our "non MVC" based systems to the QModelIndex/Model world.. But once you learned how to think in the new world, it wasn’t too bad.. The issue became a matter of "re-write" not Qt3-4 ports.

If it were up to me.. I would love to see Qt focus on containers that Qt MUST have that add SIGNIFICANT value to the Qt world, NOT "well when we started, there was no stl" version.  For instance, I do see the value of QString for translation in the Qt world.  Others may disagree, but QList std::list or std::vector, or QSet, makes NO sense to me for Qt to keep.

Scott





More information about the Development mailing list