[Development] Requiring minimum GCC 7/MinGW (was: Dropping MinGW support in Qt 6 (Was: HEADS-UP: QStringLiteral))

Thiago Macieira thiago.macieira at intel.com
Thu Aug 22 17:09:49 CEST 2019


On Wednesday, 21 August 2019 17:17:17 PDT Kevin Kofler wrote:
> > So let me instead change my request:
> > Can we require GCC 8 for MinGW for Qt 5.15?
> 
> This is a much more reasonable request than the original one.
> 
> For what it's worth, the oldest still supported Fedora release (Fedora 29)
> has a cross-MinGW-w64 GCC 8.3.0. (My machine with 7.3.0 is out of date and
> scheduled (by me) to be upgraded tomorrow, so you're lucky that I was still
> able to easily test that version today.  ) So requiring GCC 8 should be
> fine from our side (even though it looks like GCC 7 would be enough, maybe
> even an earlier version).

Since GCC 7 is working, we can require GCC 7 for MinGW for 5.15, hopefully 
5.14 so I can begin ressurrecting the Q_THREAD_LOCAL patches.

Can we do that?

-- 
Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel System Software Products





More information about the Development mailing list