[Development] HEADS-UP: QStringLiteral

Tor Arne Vestbø Tor.arne.Vestbo at qt.io
Thu Aug 22 17:46:55 CEST 2019


> On 22 Aug 2019, at 17:39, Mutz, Marc <marc at kdab.com> wrote:
> 
> Aye, it's more to _think_ and to _write_, but we don't care about those metrics.

Don’t say “we”, when you mean “I”. This hits the nail on the head. You may not care, but I for one do.

> The same goes for QList vs. QVector vs. std::vector. Anyone who claims that one is any more or less readable than the other is ... to say it politely ... mistaking brevity for clarity.

Yes, clearly these are equal in readability:

    if (std::find(v.begin(), v.end(), x) != v.end())

    if (v.contains(x))

🤦🏼‍♂️

Tor Arne


More information about the Development mailing list