[Development] Looking for Feedback QDeferred

Elvis Stansvik elvstone at gmail.com
Mon Feb 11 13:10:46 CET 2019

Looks nice! From an API perspective I would call the provider APIs
fail(...) and succeed(...) instead of reject(...) and resolve(...),
and the corresponding consumer APIs onSucceeded(...) and onFailed(...)
(or whenSucceeded(...) / whenFailed(...)). Or something else that
makes the connection between the two clear.

But that's just my 2 cents.


Den mån 11 feb. 2019 kl 12:50 skrev Juan Gonzalez Burgos
<juangburgos at gmail.com>:
> Hi guys,
> Sorry to bother you with yet another promise/deferred library for Qt. I am looking for feedback.
> https://github.com/juangburgos/QDeferred
> Thanks.
> _______________________________________________
> Development mailing list
> Development at qt-project.org
> https://lists.qt-project.org/listinfo/development

More information about the Development mailing list