[Development] Configure command lines of official Qt releases

Konstantin Tokarev annulen at yandex.ru
Thu Jun 6 11:38:23 CEST 2019



06.06.2019, 11:12, "Richard Weickelt" <richard at weickelt.de>:
> On 05.06.2019 21:28, Иван Комиссаров wrote:
>>  AFAIK -R . is used to load that icu libraries I told you about in Gerrit.
>>
>>  Otherwise it will try to load the system ones instead of the shipped ones with Qt.
>
> Thanks, Ivan. While this is true for other libs like xcb, Qt does not ship
> icu. It uses either the one provided by the system or a thin replacement
> resulting in a reduced localization feature set according to
> https://wiki.qt.io/Qt_5_ICU#Design_Principles

Linux binaries are shipped with ICU. It's not possible to use system version, because
ICU doesn't provide stable ABI.

-- 
Regards,
Konstantin



More information about the Development mailing list