[Development] Views

Mutz, Marc marc at kdab.com
Thu Jun 6 15:36:07 CEST 2019


On 2019-06-06 15:14, Konstantin Tokarev wrote:
[...]
> There is a principle of single level of abstraction [1], and inline
> implementation
> of flat map can be viewed of violation of such principle. If flat map
> implementations
> were kept speparately, it would indeed make code easier to read and 
> maintain.
> 
> [1] http://principles-wiki.net/principles:single_level_of_abstraction

The code factors the setting and lookup into functions already. A 
function is an abstraction. If you're concerned about a function that 
calls find_if and then uses the result, how do you rate this one: 
https://code.woboq.org/qt5/qtbase/src/widgets/kernel/qgesturemanager.cpp.html#_ZN15QGestureManager26filterEventThroughContextsERK9QMultiMapIP7QObjectN2Qt11GestureTypeEEP6QEvent

It's using _all_ the nice abstractions!

Puts some stuff into perspective, doesn't it?



More information about the Development mailing list