[Development] forcing libxkbcommon to be present in the system makes newer Qt unusable on older linux distros

Thiago Macieira thiago.macieira at intel.com
Tue Mar 5 17:22:11 CET 2019


On Tuesday, 5 March 2019 06:52:27 PST Gatis Paeglis wrote:
> "This library is present on all supported platforms."

Please note the implication on this: the Linux distribution you're using is 
NOT a supported one.

The commit removing xkbcommon explicitly says so:
http://code.qt.io/cgit/qt/qtbase.git/commit/?
id=c3a963da1f9e7b1d37e63eedded61da4fbdaaf9a

    Having libxkbcommon in 3rdparty sources is not necessary anymore, after
    RHEL 6.6 was removed from the list of supported platforms for Qt 5.12.


-- 
Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel System Software Products





More information about the Development mailing list