[Development] QtCS2019 Notes: QtCore

Thiago Macieira thiago.macieira at intel.com
Sat Nov 23 12:48:12 CET 2019


On Saturday, 23 November 2019 09:47:23 CET André Pönitz wrote:
> So let's make this a real proposal: Should we have
> 
>    qsizetype QContainer::size()
>    int QContainer::count() const

So you propose changing code like

	int n = vec.size();
to
	int n = vec.count();
while we could just change it to:
	int n = int(vec.size());

If we're going to make changes anyway, why not make the right change?

-- 
Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel System Software Products





More information about the Development mailing list