[Development] QtCS2019 Notes: QtCore
giuseppe.dangelo at kdab.com
Sun Nov 24 11:30:29 CET 2019
Il 24/11/19 10:44, Uwe Rathmann ha scritto:
> I fully agree with André - having 2 different APIs makes a lot of sense
> to me. But instead of using count/size I would use something like
> countU/sizeU. like you have QPen::widthF and QPen::width.
I disagree: it makes the API confusing. The F there stands for floating
point, as opposed to integer (and historically you don't even know
_which_ floating point you get). What would the U stand for exactly?
Giuseppe D'Angelo | giuseppe.dangelo at kdab.com | Senior Software Engineer
KDAB (France) S.A.S., a KDAB Group company
Tel. France +33 (0)4 90 84 08 53, http://www.kdab.com
KDAB - The Qt, C++ and OpenGL Experts
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 4329 bytes
Desc: Firma crittografica S/MIME
More information about the Development