[Development] Proposal: Deprecate QVector in Qt 6

Christian Ehrlicher Ch.Ehrlicher at gmx.de
Fri Apr 24 09:33:49 CEST 2020

Am 24.04.2020 um 09:22 schrieb Lars Knoll:
>> e "vector is a silly name from a mathematical standpoint" argument is valid, but vector is an established term in C++ world. Sorry, that ship has sailed.
>> I am also in favor of proposal 2 or 3. I think deprecating either QList or QVector without any big advantage for the user will just make porting form Qt5 to Qt6 needlessly harder.
>> Even inside Qt we are struggling to keep up with deprecation warnings (Thanks to Friedemann for fixing these). I am pretty sure Creator does have the same "problem". Extrapolating that from "just us" to the broader audience we are hopefully targetting, it looks like lots of users/applications will be hit by these warnings and it will mean (lots of?) work for them.
> I do agree that we shouldn’t deprecate neither name, as that would just make moving from 5 to 6 harder. The unification of the classes should help simplify things.
> But we need to have a consistent message around which name is the preferred one and used in Qt’s own API and documentation. Having a QList in one method and a QVector in the next one would only be confusing to our users. So IMO this thread should mainly be about deciding what the default name for this container is in our documentation and API in Qt 6.
Since you tell everyone since ages that QList should not be used (it's
in the documentation since 5.6:
https://doc-snapshots.qt.io/qt5-5.9/qlist.html#details , Marc wrote
about not using QList in 2010 ) and the discrepancy between std::list
and QList I don't understand what's to be discussed here at all.


More information about the Development mailing list