[Development] A modest proposal: disable lower-case keywords (emit, foreach, forever, signals, slots) by default

Kai Köhne Kai.Koehne at qt.io
Wed Feb 26 09:02:34 CET 2020


Hi,

There are now 73 results to the survey, current results are at 

https://bugreports.qt.io/secure/attachment/92413/survey_result.pdf

I tried to aggregate also the other suggestions, and ordering by absolute votes:

mySignal()  - 21 votes
Q_EMIT mySignal() - 13 votes
[[qt::emit]] mySignal() - 12 votes
qemit mySignal() - 5 votes
emit mySignal() - 3 votes
qEmit(mySignal) - 1 vote
keep the \"ugly\" q_emit but don\`t require it. - 1 vote
method call with naming convention - 1 vote
mySignal() // emit, let a comment look lik a comment - 1 vote
[[emit]] - 1 vote
emitmysignal()  - 1 vote

Thanks for participating!

Kai

> -----Original Message-----
> From: Development <development-bounces at qt-project.org> On Behalf Of Kai
> Köhne
> Sent: Monday, February 24, 2020 4:31 PM
> To: Ville Voutilainen <ville.voutilainen at gmail.com>; Lars Knoll
> <lars.knoll at qt.io>
> Cc: Thiago Macieira <thiago.macieira at intel.com>; Qt development mailing
> list <development at qt-project.org>
> Subject: Re: [Development] A modest proposal: disable lower-case keywords
> (emit, foreach, forever, signals, slots) by default
> 
> Hi,
> 
> Since this is arguably as much about taste as it is about technicalities, I
> thought it might be interesting to do a quick poll in the form of a survey:
> 
> https://www.1ka.si/a/255723
> 
> Disclaimer: Qt Project is not a democracy, so let's not pretend that whatever
> gets most clicks gets implemented in the end. Still, I'm curious ...
> 
> Kai
> 
> > -----Original Message-----
> > From: Development <development-bounces at qt-project.org> On Behalf Of
> > Ville Voutilainen
> > Sent: Monday, February 24, 2020 2:53 PM
> > To: Lars Knoll <lars.knoll at qt.io>
> > Cc: Thiago Macieira <thiago.macieira at intel.com>; Qt development
> > mailing list <development at qt-project.org>
> > Subject: Re: [Development] A modest proposal: disable lower-case
> > keywords (emit, foreach, forever, signals, slots) by default
> >
> > On Mon, 24 Feb 2020 at 14:42, Lars Knoll <lars.knoll at qt.io> wrote:
> > > But we could convey the information that this is a signal you’re
> > > calling
> > *reliably* through other means. This implies that the keyword is not
> required.
> >
> > Was the keyword ever required? Seems like it's just a taste difference
> > from a
> >
> > qEmit(my_signal());
> >
> > to write
> >
> > emit my_signal();
> >
> > The first one can be namespaced, and thus its name lookup controlled.
> > It also never clashes with a member name.
> > Its worse aesthetics aside, if we'd had that since the beginning, we
> > wouldn't be talking about the current clashes with std::osyncstream.
> > _______________________________________________
> > Development mailing list
> > Development at qt-project.org
> > https://lists.qt-project.org/listinfo/development
> _______________________________________________
> Development mailing list
> Development at qt-project.org
> https://lists.qt-project.org/listinfo/development


More information about the Development mailing list