[Development] Suggesting update brace placement following a multi-line if condition
Lorn Potter
lorn.potter at gmail.com
Sun Jul 19 23:34:24 CEST 2026
On 16/7/26 19:14, Marc Mutz via Development wrote:
> I would therefore like to propose to allow placing the opening brace
> on a separate line if the if condition is multi-line:
> // (now also) Correct if (address.isEmpty() || !isValid() || !codec) {
> return false; }
But then there's a special carve-out of the rules for this one case
(besides the function exception). To make the original more readable,
simply use a new blank line after the opening brace.
and going forward there would be a mismatch of bracing styles for this
new exception.
and ewww.. that new style would bother me because it looks out of place.
More information about the Development
mailing list