<div dir="ltr">sorry, <div><br></div><div style>I have finded the issue .. A previous linked library (Qt4) to the apps that I have copy in /usr/lib ... and forgotten .. I have trash the old lib, and now It links and works correctly ...</div>
</div><div class="gmail_extra"><br><br><div class="gmail_quote">2013/10/21 Ziller Eike <span dir="ltr"><<a href="mailto:Eike.Ziller@digia.com" target="_blank">Eike.Ziller@digia.com</a>></span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="im"><br>
On 20.10.2013, at 21:34, qtnext <<a href="mailto:qtnext@gmail.com">qtnext@gmail.com</a>> wrote:<br>
<br>
> I use now Qt5.1.1, try to erase all Qt4 lib in my mac .. And I have always the same trouble. When I start macdeploy with verbose=2, I have the following error :<br>
> ....<br>
> ERROR: no file at "/Library/Frameworks/QtScript.framework/Versions/4/QtScript"<br>
> ERROR: no file at "/Library/Frameworks/QtCore.framework/Versions/4/QtCore"<br>
> ERROR: no file at "/Library/Frameworks/QtSvg.framework/Versions/4/QtSvg"<br>
> ERROR: no file at "/Library/Frameworks/QtGui.framework/Versions/4/QtGui"<br>
> ERROR: no file at "/Library/Frameworks/QtXml.framework/Versions/4/QtXml"<br>
> ERROR: no file at "/Library/Frameworks/QtNetwork.framework/Versions/4/QtNetwork"<br>
> ....<br>
> Log: Deploying Qt frameworks found inside: ("myapp.app/Contents/PlugIns/sqldrivers/libqsqlmysql.dylib")<br>
> ERROR: no file at "/usr/lib/libmysqlclient.18.dylib"<br>
<br>
</div>macdeployqt scans the binary of your application (and any dynamic lib it finds in the bundle) with "otool -L" and tries to extract the Qt location from there. The above means that it finds some binary or dylib in the application bundle that is linked against Qt4. The verbose log should give you a hint of where that is found in.<br>

<div class="im"><br>
> -> When I try to launch the apps after, it crash and I have the following message :<br>
> "<br>
> Crashed Thread:  0<br>
><br>
> Exception Type:  EXC_BREAKPOINT (SIGTRAP)<br>
> Exception Codes: 0x0000000000000002, 0x0000000000000000<br>
><br>
> Application Specific Information:<br>
> dyld: launch, loading dependent libraries<br>
><br>
> Dyld Error Message:<br>
>   Symbol not found: __ZN7QObject13connectNotifyEPKc<br>
>   Referenced from: /Volumes/VOLUME/*/myapp.app/Contents/MacOS/../Frameworks/libModuloMediaLib.1.dylib<br>
>   Expected in: /Volumes/VOLUME/*/myapp.app/Contents/MacOS/../Frameworks/QtCore.framework/Versions/5/QtCore<br>
> "<br>
><br>
> The strange things is I have to other application, one very small (qtwidget based) and one C++/Quick2 that is working fine<br>
<br>
<br>
> when I remove the // with scripts.<br>
<br>
</div>What do you mean with that?<br>
<br>
Br, Eike<br>
<span class="HOEnZb"><font color="#888888"><br>
--<br>
Eike Ziller, Senior Software Engineer - Digia, Qt<br>
<br>
Digia Germany GmbH, Rudower Chaussee 13, D-12489 Berlin<br>
Geschäftsführer: Mika Pälsi, Juha Varelius, Anja Wasenius<br>
Sitz der Gesellschaft: Berlin, Registergericht: Amtsgericht Charlottenburg, HRB 144331 B<br>
<br>
</font></span></blockquote></div><br></div>