<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="FI" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal">Hi all!<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span lang="EN-US">We’ve been going back to defining what “supported platform” means many times. This time however I want to loosen the reins a bit:<o:p></o:p></span></p>
<p class="MsoNormal"><a href="https://codereview.qt-project.org/c/qt/qtdoc/+/269546"><span lang="EN-US">https://codereview.qt-project.org/c/qt/qtdoc/+/269546</span></a><o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span lang="EN-US">We stumble upon a problem where the distro itself isn’t supported and / or its repositories are in worst cases removed, but we claim that our LTS release still supports it, and nothing newer. Thus I suggest we change
 the terminology to say that Qt supports anything beyond that was existing when we released Qt. Note, that I don’t say “we support” as The Qt Company, but what Qt supports, and that’s what the documentation is about really.<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p> </o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">MacOS is another good example where we claim to support the latest 3 available at the time of release. But in 4 years of an LTS release we actually don’t have a single one of those 3 left that were out when we released
 5.x.0. Are we now supporting the ones documented when the initial minor release came out, or the latest 3 available at the time of the latest patch release? Especially when talking about macOS people tend to update to the latest one, so why support older ones.
<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p> </o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Or should we go ahead and rewrite that documentation even more? We say that Qt 5.12 supports Ubuntu 18.04 with GCC 7.3, but then we say that Qt supports Generic Linux with just about any compiler. Doesn’t Ubuntu sit in
 this category already? Wouldn’t it be enough that we say Linux with GCC 4.8+?<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p> </o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">And different features have different library dependencies. Nothing prevents you from using Qt 5.12 on SLES 12, but you won’t get QtWayland there. Or bluez this and that version is needed for specific Bluetooth features
 to enable which aren’t necessarily available in a stock RHEL 6.x series. So let’s add library dependencies to the list?<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p> </o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">I think that in general if there is a bug in Qt for any major distro, the bug will get fixed. How often is the response that Qt does’t support that? The documentation part should definitely define the minimum compiler
 version that is needed, just as the talk currently about Qt6 that’s going on in a different thread. But beyond that to what comes to the distros we support, I don’t think we should document it so tightly what we support, because of the reasons above.<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p> </o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">And just as a reminder here, the stuff that’s in the CI have “nothing” to do with what Qt supports, or even what The Qt Company supports. The CI tries to cover the most common use cases, the latest compilers to cover
 where we are going, and the minimum set so that we don’t start regressing from the rear. And Qt packages (Qt binaries) can even be done with a distro that’s been modified with libraries built from sources and thus making it a custom distro in a way, only so
 that The Qt Company’s Linux binaries work in most Linuxes. Not an issue in macOS or Windows worlds naturally.<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p> </o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Regards,<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">-Tony <o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p> </o:p></span></p>
<p class="MsoNormal"><span lang="EN-US" style="mso-fareast-language:FI"><o:p> </o:p></span></p>
</div>
</body>
</html>