<div dir="ltr">Yeah, I understand the reasoning, because of lack of ABI compat with minor updates/patches, etc.<div><div><div><br></div><div>However, our proprietary GUI needs it. I'll work on recompiling that module with private headers and deploy the deb within our own internal apt-feed.</div></div></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Fri, Nov 29, 2019 at 3:04 AM Pier Luigi Fiorini <<a href="mailto:pierluigi.fiorini@gmail.com">pierluigi.fiorini@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div dir="ltr"></div><div class="gmail_quote"><div dir="ltr" class="gmail_attr">Il giorno ven 29 nov 2019 alle ore 08:44 Paul Knopf <<a href="mailto:pauldotknopf@gmail.com" target="_blank">pauldotknopf@gmail.com</a>> ha scritto:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr">I'm working on getting Debian 10 working for my Linux appliance/device and our GUI uses Qt.<div><br></div><div>Specifically, it uses "CONFIG+=multimedia-private".</div><div><br></div><div>There seems to be a bunch of private Qt headers in the official repos, but non for qtmultimedia5.</div><div><br></div><div>There looks to be history of "qtmultimedia5-private-dev", but it doesn't exist anywhere anymore.</div><div><br></div><div>I found this: <a href="https://metadata.ftp-master.debian.org/changelogs/main/q/qtmultimedia-opensource-src/unstable_changelog" target="_blank">https://metadata.ftp-master.debian.org/changelogs/main/q/qtmultimedia-opensource-src/unstable_changelog</a></div><div><br></div><div>---</div><div>  * Remove package qtmultimedia5-private-dev. Nothing in the Qt stack seems to<br>    be using it. Can be reintroduced later if needed.<br>    - Remove associated install file.<br>    - Remove the files from debian/tmp before installing the packages.<br></div><div>---</div><div><br></div><div>Can anyone provide me with some context?</div></div>
</blockquote></div><div><br></div><div>Debian doesn't ship private headers, unless they are needed by the Qt stack.<div>Using private headers in third party applications is not recommended.</div></div><div><br></div>-- <br><div dir="ltr"><div dir="ltr"><div><div dir="ltr"><div><a href="https://liri.io" target="_blank">https://liri.io</a></div></div></div></div></div></div>
</blockquote></div>