[Interest] DBus multithreading problems with Qt 4.8

christian_weilbach at web.de christian_weilbach at web.de
Fri Mar 9 22:10:12 CET 2012


I have tried to debug a problem for some months in my KDE ioslave in KTorrent. 
It basically exposes the DBus interface of KTorrent to provide IO-
functionality for all KDE/Qt-apps for magnet-bittorrent-links in a new URL 
shema. (1)

It has worked fine (besides some occasional hickups) for Qt 4.7, but suddenly 
stopped working when switching to Qt 4.8. I have only recognized it because it 
stopped working on Fedora 16, which was like Kubuntu 11.10 KDE 4.7 and DBus 
1.4, but had Qt 4.8 already deployed. I don't get an error, I simply don't get 
the signals from KTorrent in the event loop of DBusHandler. (2) See line 212 
for the lost signals and (3) for the KIO-slave, it is run from DBusThread (4). 
To build the slave you need to enable it in cmake by setting the 
ENABLE_KIO_MAGNET option to "true". Test it on a free torrent. (5)

Nobody can help me on #kde-devel or the kde-devel list and I am out of ideas. 
What can I do to make it work again? I am likely doing it wrong, but am stuck. 
Has anything significant changed in Qt 4.8 in this regard?


(1) http://whilos.blogsite.org/?p=157
(5) https://thepiratebay.se/search/vodo/0/99/0

More information about the Interest mailing list