[Interest] Building Qt for debugging - libwebcore.a File format not recognized

Carl L Schumann schumann at fnal.gov
Sun May 6 14:50:30 CEST 2012

On May 6, 2012, at 3:29 AM, Alexander Semke wrote:

> Hi,
>> This resulted in the following error when Makefile.WebKit.QtWebKit tried
>> to build libQtWebKit.so.4.9.0:
> From qt-webkit docu:
> "Note: Building the QtWebKit module with debugging symbols is problematic on 
> many platforms due to the size of the WebKit engine. We recommend building the 
> module only in release mode for embedded platforms. Currently QtWebKit will 
> always be compiled without debugging symbols when using gcc. Take a look at 
> the last lines of src/3rdparty/webkit/WebCore/WebCore.pro if you need to 
> change this."
> This may explain the problem you've experienced.
> Alexander

We actually had more problems when tried not to build webkit.    Though the part about needing a lot of memory appears to be correct either way.

More information about the Interest mailing list