[Interest] compiling qt with eglfs

Girish Ramakrishnan girish at forwardbias.in
Sat Nov 10 00:53:56 CET 2012

On Fri, Nov 9, 2012 at 4:22 AM, pritam.ghanghas at gmail.com
<pritam.ghanghas at gmail.com> wrote:
> On Fri, Nov 9, 2012 at 11:16 AM, pritam.ghanghas at gmail.com
> <pritam.ghanghas at gmail.com> wrote:
>> On Thu, Nov 8, 2012 at 8:06 PM, pritam.ghanghas at gmail.com
>> <pritam.ghanghas at gmail.com> wrote:
>>> On Thu, Nov 8, 2012 at 8:00 PM, Samuel Rødal <samuel.rodal at digia.com>
>>> wrote:
>>>> On 11/08/2012 01:55 PM, pritam.ghanghas at gmail.com wrote:
>>>> > I am still stuck with qt 4.8.3 with qpa. It always compiles, but I
>>>> > never
>>>> > got it to work.
>>>> > Now when i try the application its failing at load time itself
>>>> > # ./hellogl_es2 -qpa -platform egl
>>>> > Failed to load platform plugin "egl". Available platforms are:
>>>> > Minimal
>>>> >
>>>> > if I try Minimal, I get a segfault.
>>>> > ./hellogl_es2 -qpa -platform Minimal
>>>> > Segmentation fault
>>>> >
>>>> > backtrace from gdb shows that it crashes in
>>>> > QGLContext::chooseContext(QGLContext const*) ()
>>>> The minimal plugin doesn't support OpenGL.
>>>> > I have no idea what to do next. why didn't I get eglfs plugin when I
>>>> > had
>>>> > specified -egl in configure.
>>>> Try specifying -eglfs and -opengl es2 when running configure and see
>>>> what the configure output says.
>> -eglfs was not recognized by configure as a valid option.
>>> I will try that tomorrow. I had tried specifying -qpa eglfs. But that
>>> didnt help.
>>> I compiled by actually going to  src/plugins/platforms/eglfs.
>>> Surprisingly makefile was there. The build system ran qmake on it, but
>>> somehow never ran make.
>>> Right now I dont have board to test it. I will get board again tomorrow.
>>> I will test it and let you know.
>> I have the plugin manually compiled. It loads but fails to create surface.
>>  Could not create the egl surface: error = 0x300b
>> I think I need to do some platform specific patching in plugin. I am
>> looking into that now.
> Finally I got graphcis working with qt 4.8.3 + egl + opengl with a little
> bit of custom platform initialization in qeglfsscreen.cpp. But now I have a
> new problem. No input in qpa application, neither mouse nor keyboard.
> I googled a little bit and found that I should supply -plugins manually
> while running application.
>  ./animatedtiles -plugin LinuxInputMouse:/dev/input/mouse0  -qpa -platform
> EglFS
> Still no cursor or mouse input. Any ideas ?

eglfs supports display of mouse cursor only in Qt. I added this in
https://codereview.qt-project.org/#change,23118. You should be able to
backport it. As for mouse input, double check if the input device path
(/dev/input/mouse0) is correct. Just put a debug in the input plugin.
The mouse should also probably be plugged in before the program starts
since the mouse input plugin doesn't support udev (the qt5 version
supports it though)


More information about the Interest mailing list