[Interest] About Qt 4.8.3 MinGW

R. Reucher rene.reucher at batcom-it.net
Mon Sep 24 13:16:40 CEST 2012

On Monday 17 September 2012 11:28:07 Salovaara Akseli wrote:
> Qt 4.8.3 MinGW package is partially broken as we notified in the mailing
> lists. We will provide a new installer to fix these issues (work in
> progress).
Could you also post links to the source changes when it's done?

I'm able to build Qt 4.8.3 cleanly with MinGW (32- and 64-bit), however, as I 
already stated in the "Qt 4.8.3 / MinGW: JavaScriptCore doesn't compile" 
thread, qmake isn't working properly for my projects. Now I tried the official 
MinGW Qt 4.8.3 binary package, and it apparently has the same qmake issue...

This is the package I tried:

Also, can someone confirm that we are seeing the same issue(s)?

To clarify what's wrong from my perspective, I quote myself:

"... it seems that qmake from this build doesn't work properly as it exposes 
empty values for QT_VERSION (and QT_MAJOR_VERSION, QT_MINOR_VERSION etc.), but 
others like CONFIG or QT for example have valid values... that's weird to say 
the least ;)!


I should add that "qmake -query QT_VERSION" returns the string "4.8.3" 
correctly, but it's empty when qmake processes a .pro file (i.e. in makefile-

Cheers, René

More information about the Interest mailing list