[Interest] touch functionality not working with my Qt 5 apps

VStevenP vstevenpavao at yahoo.com
Fri Apr 12 19:08:31 CEST 2013

On 12 Apr 2013, at 5:20 PM, fsjunior wrote:

> VStevenP <vstevenpavao <at> yahoo.com> writes:
>> I am trying to figure out why the touch functionality of my LG display 
> isn't working with my Qt 5 apps.
>> The touch technology is an N-trig DuoSense which is easily auto-detected 
> and added as a USB input device by
>> Angstrom 2011.03 (kernel 2.6.32) on my BeagleBoard-xM.
>> (Note that kernel 2.6.31 and greater has mainline support for N-trig, and 
> that Angstrom 2011.03 is
>> configured with CONFIG_HID_NTRIG=y, which allows the touch functionality 
> to work with Angstrom).
>> However, when I run my Qt 5 apps on the BeagleBoard-xM, touching the 
> display doesn't result in cursor
>> control, and swipe gestures do nothing.  The mouse works fine, however.
>> Shouldn't the touch functionality work automatically in this situation? 
>  Note that the the touch
>> functionality provided by the N-trig DuoSense can actually successfully 
> control the mouse on my MacBook
>> Pro if I simply plug it into it via USB.  I can make selections in apps, 
> etc.
>> I'm hoping there's something obvious I'm missing, because this combination 
> of technologies should work,
>> from what I understand.
> Hi VStevenP,
> I am having the "same" problem. I use Angstrom 2011.03 and kernel 2.6.32. 
> But in my case even the tslib test software get any position event.
> Do you have any advance in your problem?

A colleague discovered that with the current tslib plugin/kernel (2.6.32) the N-Trig controller doesn't work.  A cat "/dev/input/touchscreen0 | hexdump" showed that the controller receives data and seems to be ok, but the module_raw is not able to translate them correctly, as shown running ts_print_raw command. The coordinates and pressure values are always set to 0 and changing module in /etc/ts.conf doesn't help either. With some printf debugging in the library he saw that the N-Trig sends events that the module_raw is not able to translate, so it drops them.

My colleague will be looking at a workaround for us sometime in the future.

You might try subscribing to the beagleboard googlegroup.  Others have posted about similar problems in the past and maybe someone has worked around it already.  If you are able to find a solution there, please share back if possible.

- VStevenP

More information about the Interest mailing list