[Interest] QtCreator 2.8.0 and CentOS 6.4: No go

Bob Hood bhood2 at comcast.net
Thu Aug 8 23:02:14 CEST 2013

I have to do some Qt development work with CentOS 6.4 and Qt 4.8.4.  Out of
the box, CentOS 6.4 provides "gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-3)". 
Attempting to install QtCreator 2.8.0 is a miserable failure because any
useful plug-in refuses to load:

Cannot load plugin because dependency failed to load: CppTools(2.8.0)
Reason: Cannot load plugin because dependency failed to load:
Cannot load library
(/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by

and so on.

I've tried installing the "test" devtools 1.1 to get gcc 4.7.x, but I cannot
seem to get QtCreator to see it.

I've also tried building QtCreator from source, using gcc 4.4.7, and pointing
it at Qt 4.8.4, but it ultimately errors out on the QtHelp project with C++

Is there any hope that I can use QtCreator as my development IDE with this
Linux distro?

More information about the Interest mailing list