[Interest] Failure building and deploying Qt Quick application to Android

Chao Caroline Caroline.Chao at digia.com
Fri Aug 16 15:33:40 CEST 2013


I think you are not using the correct ant version. The log states you are using "/usr/bin/ant"

You should used: Apache Ant v1.8 or later


From: interest-bounces+caroline.chao=digia.com at qt-project.org [interest-bounces+caroline.chao=digia.com at qt-project.org] on behalf of Aaron McCarthy [mccarthy.aaron at gmail.com]
Sent: Friday, August 16, 2013 2:44 PM
To: interest at qt-project.org
Subject: [Interest] Failure building and deploying Qt Quick application to      Android


I'm trying to build and deploy the Qt Quick template application created in Qt
Creator. The C++ part of the application build fine. However, during the
deploy stage, when the java wrapper gets built, it fails with java compile
error, see the attached deploy-log.txt.

My setup:
Debian unstable x86_64
Qt 5.1.0 for android x86_64 version
Android NDK r8e
Android SDK (updated to the latest version)
I'm using Oracle JDK, but have also tried OpenJDK and get the same error.

Internet searching indicates that the java compiler is configured to target an
incompatible source or binary version. And indeed the build.xml (which is part
of the Android SDK) referenced at the end of the attached deploy-log.txt

<property name="java.target" value="1.5" />
<property name="java.source" value="1.5" />

where apparently java 1.6 is required. I tried changing the value attributes
to "1.6", which I think is the correct change, but that just gives me another

javac: invalid target release: 1.6

Does anyone have any idea what is wrong with my setup?


Aaron McCarthy

More information about the Interest mailing list