[Interest] QtLinuxFB no mouse or keyboard

yahoo pers yours_pass at yahoo.com
Fri Aug 30 22:03:32 CEST 2013

My keyboard is detected as /dev/input/event0   and my  mouse  as /dev/input/mice
In my app i have a QLineEdit and when it starts i can see the cursor blinking in it.
I tried:
export QT_QPA_EVDEV_KEYBOARD_PARAMETERS="/dev/input/event0" 
sudo ./app -platform linuxfb

but still no keyboard.

then i tried:
./app -platform linuxfb -plugin EvdevKeyboard:/dev/input/event0
but still no keyboard.

 From: Knight Andrew <Andrew.Knight at digia.com>
To: yahoo pers <yours_pass at yahoo.com>; "interest at qt-project.org" <interest at qt-project.org> 
Sent: Friday, August 30, 2013 7:43 AM
Subject: RE: [Interest] QtLinuxFB no mouse or keyboard

> A also wrote on the forum and i got help to build qt5 and run the app but couldn't get help about the mouse and keyboard problem.

Some QPA plugins, like LinuxFB, don't load their own input handlers, so you need to do this yourself by passing additional -plugin arguments when you start your app. These are called "generic" plugins and can be found in qtbase/src/plugins/generic. For example:

./myapp -platform linuxfb -plugin EvdevMouse -plugin EvdevKeyboard

Those plugins will automatically try to open the first mouse/keyboard in /dev/input. Make sure the user has read permissions for those devices (you should see warning messages if opening fails). For specifying additional parameters that get passed to the plugin(s), please consult each individual plugin's source code.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20130830/2e15812d/attachment.html>

More information about the Interest mailing list