[Interest] Gerrit integration failure on unrelated test

Thiago Macieira thiago.macieira at intel.com
Thu Jun 13 18:36:34 CEST 2013

On quinta-feira, 13 de junho de 2013 18.20.22, Samuel Gaist wrote:
> Hi,
> I would like to know what is the proper course of action when an integration
> fails because of something unrelated.
> I've tried to merge two patches for OS X ui related bug in qtbase and the CI
> tells me that tst_QsslSocket fails for win32 mingw47 on windows 7. It all
> seems related to time out issues.

If the integration fails for a test failure that is either spurious or caused 
by another commit that went into testing along with yours, you can just click 
the Stage button again.

Many of the network tests fail with timeouts every now and then. Those are 
spurious errors.

The errors from the past 18 hours were not spurious. If the tests fail because 
a network test is saying "Connection refused" -- especially if it is the 
networkselftest -- it means one of the daemons on the test server crashed. 
Clicking Stage again will only cause the same error again, even if not related 
to you. Wait for European regular working hours for one of the admins to 
handle the issue.

Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel Open Source Technology Center
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20130613/1336d32a/attachment.sig>

More information about the Interest mailing list