[Interest] macdeployqt for Qt5.2beta issues on OSX Lion

Joshua Grauman jnfo-c at grauman.com
Thu Nov 14 02:05:40 CET 2013

I just finished getting my app ready to run with Qt5.2beta and OSX Lion 
and everything is running fine. However, after I run macdeployqt, I can't 
run the app by double clicking on it, it just immediately crashes. When I 
run it from the terminal it is fine. I ran otool -L on the binary and 
everything looked good, and macdeployqt worked fine for me with Qt5.0.1. 
The only change I could think of besides switching to Qt5.2beta is that 
I'm now invoking clang directly via make (ie. just running qmake without 
options which generates a Makefile and then make), rather than running 
qmake with options to create an xcode project, and then running the 

I can't think of any reason why running on the commandline would work, but 
running by double clicking the icon wouldn't. Does anyone have any ideas 
about what else to check? Thanks so much!


More information about the Interest mailing list