[Interest] Disable Qt Concurrent in 5.1 for simple RTOS

George Seibert gseibert92 at gmail.com
Wed Oct 2 02:12:59 CEST 2013


Has anyone compiled Qt 5 for a simple RTOS without threading?

I'm trying to compile Qt 5.1 for a small in-house RTOS which doesn't have
threading.  I've tried -no-feature-concurrent, as well as -no-concurrent
which isn't understood by configure, but Qt Concurrent is still reported as
"yes" at the end of running configure.

I've used the configure switch -no-feature-thread to disable threads, but
I've run into compile errors regarding QThreadData.  This, after solving a
compile error in qpropertyanimation.cpp that was missing an #ifndef
QT_NO_THREAD around the QMutex locker.unlock() call.  The errors regarding
QThreadData are more complex (invalid use of incomplete type in qthread_p.h
and forward declaration in qobject.h).

I'm fairly sure I can solve the compile errors, but the errors lead me to
believe I'm not properly disabling threads/concurrency using configure.
How do I disable threads and concurrency?

Also, is there any way to disable the networking features?  According to
the configure help, you can disable features with the -no-feature-<FEATURE>
switch, with features listed in qfeatures.txt.  I've tried, for example,
-no-feature-getaddrinfo, yet it's still reported as "yes" at the end of
running configure.

Any help is much appreciated!

Thank you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20131001/13ddf869/attachment.html>

More information about the Interest mailing list