[Interest] Qt 5.2 basic example on iOS not working, what am I doing wrong?

Turunen Tuukka Tuukka.Turunen at digia.com
Sat Feb 1 13:37:32 CET 2014

Hi Thomas,

The examples problem was very unfortunate, I am sure you are not the only one who hit it. It is already fixed and becomes available when Qt 5.2.1 / Creator 3.0.1 are released.




"Thomas Sevaldrud" <thomas at silentwings.no<mailto:thomas at silentwings.no>> kirjoitti 30.1.2014 kello 1.05:

Ok... so now I finally have it working :-) Although there are still a couple of small issues...

First of all, I noticed that regardless of what I selected on the combobox in the Examples browser, it always loaded the examples from the "clang_64" folder. So I tried loading the examples directly from the .pro files under ios/examples in the Qt installation dir, and then it worked! All examples I tried this far worked nicely :-D

It would seem that there is a little bug in the examples browser then. Probably worth fixing, since I can't imagine that I am the only one trying to run the examples from the examples browser :-) I can make a bug report on it.

The next issue is my "Hello World" app... And that still baffles me. I created a new one, identical to the first one (copied the source files from the first test). The only difference was the name, and now it suddenly worked! Next I tried setting a different target name in the .pro file for the first project, and then that too worked!

Obviously there must be some bogus state cached somewhere that I can't get rid of. I've tried deleting the shadow build directories of course, as well as the $HOME/Library/Application Support/iPhone Simulator, but still no luck. As long as I call the app anything but QtMobileTest it works, but that particular app name is apparently banned forever...

Oh well, I can live with that, but it still is weird...

- Thomas

On Wed, Jan 29, 2014 at 10:09 PM, Thomas Sevaldrud <thomas at silentwings.no<mailto:thomas at silentwings.no>> wrote:
Now I've tried a lot of different things, and had some success, but mostly failures...

First of all It appears that you need to actually compile something in XCode before you can use the command line tools from Qt Creator. I just made a dummy iOS application from a template. The first time I compiled it in XCode I got a dialog box asking me if I wanted to enable "Developer Mode" or something on my Mac. After doing this, and going back to Qt Creator, my Qt test app worked!

This was with the Qt for Android and iOS package: http://download.qt-project.org/official_releases/qt/5.2/5.2.0/qt-mac-opensource-5.2.0-android-ios-x86_64-offline.dmg

Then I tried the Qt Examples again, but it still won't compile. After a bit of googling I found that this looked very much like the following bug:


But this is supposed to be fixed in Qt 5.2.0. So I thought I'd do a reinstall of the Qt package. This time I go back to the iOS only package, i.e this one:


After installing it, I make sure that I have selected "Qt 5.2.0 for iOS" on the combobox in the examples browser and try compiling a random example tagged with ios. Same problem, no Qt headers can be found. Exactly the same behavior as described in the bug report.

And on top of that, my own simple "Hello World" app stopped working in the simulator again :-(

Now, I'll try the online installer to see if that works better, but right now I'm starting to lose faith a bit :-)

- Thomas

On Tue, Jan 28, 2014 at 7:35 PM, Thomas Sevaldrud <thomas at silentwings.no<mailto:thomas at silentwings.no>> wrote:
I took the one called Qt 5.2.0 for iOS:


This package installed kits for Mac Desktop as well as iOS device and iOS simulator.

This is so weird... I guess other people has this working, right?

- Thomas

Den 28. jan. 2014 kl. 07:47 skrev Till Oliver Knoll <till.oliver.knoll at gmail.com<mailto:till.oliver.knoll at gmail.com>>:

Am 28.01.2014 um 00:39 schrieb Thomas Sevaldrud <thomas at silentwings.no<mailto:thomas at silentwings.no>>:

the examples that are installed with qt, and which are tagged with "ios" in Qt Creator. None of these will even compile when targeting the iOS simulator. None of the Qt headers can be found when compiling for iOS..

Uhm... This might sound stupid, but which Qt binary package did you install? There are distinct ones for "Mac Cocoa" (desktop) and "Mac iOS" development on the download page...

Interest mailing list
Interest at qt-project.org<mailto:Interest at qt-project.org>

Interest mailing list
Interest at qt-project.org<mailto:Interest at qt-project.org>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20140201/fe34565b/attachment.html>

More information about the Interest mailing list