[Interest] Qt3D compile with Qt5 failed

Christoph Kurz c.kurz at melph.de
Tue Feb 18 14:38:35 CET 2014

I had the same problem a few days ago, when I downloaded Qt3D as a .zip file. I
don't know the cause for the problem, but I solved it:
When I used git to clone the repository, it compiled fine.

But I have another problem now: Qt3D is compiled on Windows, the .dll files
exist and are in the right directory, even highlighting in QtCreator works and
the examples and my own 3D-programs compile without error. But when I run them
(examples or my own projects), I only see a black or white screen. Any hints?


> Hi
> I'm having troubles compiling Qt3D on Windows. The module compiles and
> links properly on my Linux machine with Qt 4.8.1. Though on Windows (Qt
> 5.2 personal build) g++ says <Qt3D/qt3dglobal.h> header is not found.
> I've compiled qt3d on linux with following these steps:
> 1. Download a tarball of branch qt4 from here, extract it.
> 2. qmake CONFIG+=package
> 3. make -j4
> 3. sudo make install
> And for Windows (Qt 5.2 gcc-4.8.1 personal build):
> 1. Download tarball of master branch from here, extract it
> 2. qmake
> 3. make // => error: missing headers
> What I'm missing?
> Note: ActiveState Perl is in PATH
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20140218/64120b1c/attachment.html>

More information about the Interest mailing list