[Interest] Bug in QtLocation 5.5 when zooming map?

Herbert Danzinger herbert.danzinger at gmail.com
Sun Jul 12 14:45:09 CEST 2015

I just tried the following QML to have a playground for integrating maps in
an Android app.
But the problem is, zooming the map on the device just does not work.
I tried that on a Nexus4 running Android 4.4 and on a Moto G with the same
result: zooming is not available.
The example mapviewer app included in Qt 5.5 works without problems though.

Am I missing something?

import QtQuick 2.5

import QtQuick.Controls 1.4

import QtLocation 5.5

import QtPositioning 5.5

ApplicationWindow {

    visible: true

    Plugin {

        id: myPlugin

        name: "osm"


    Map {

        id: map

        plugin: myPlugin

        anchors.fill: parent

        gesture.activeGestures: MapGestureArea.ZoomGesture |
MapGestureArea.PanGesture | MapGestureArea.FlickGesture

        gesture.enabled: true

        zoomLevel: 16

        Component.onCompleted: {

            console.log("Pinch enabled: " + gesture.pinchEnabled)





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20150712/7f344ddc/attachment.html>

More information about the Interest mailing list