[Interest] Qt 5.5.0 OSX Simulator fail

mark diener rpzrpzrpz at gmail.com
Fri Jul 31 03:27:04 CEST 2015

Hello List & IOS Maintainer Tor Arne:  (tor.arne.vestbo at theqtcompany.com)

I would like to suggest some hard lessons learned today.

I upgraded to 5.5.0 and was primarily getting my code running on OSX to
make sure it basically worked.  I could then deploy to IOS Simulator/IOS
and android to validate the code worked there.

I tried using Qt 5.5.0 on Yosemite 10.10.2 and Xcode 6.1.1 / 6.2 but that
turned out to be a disaster.

When I moved back to Qt 5.4.2, I gained IMMEDIATE relief.  All of the
strange xcodebuild errors went away.

The basic project I tried for HOURS to get running on IOS and IOS simulator
under Qt 5.5.0/Xcode 6.1.1 immediately WORKED on Qt 5.4.2 on Xcode 6.1.1

So I went to start looking at the CI system with an eye for knowing what
combinations of OSX, Qt 5.x.x, and Xcode 6.x are safe combinations
and which are explosive.


What I found was that the CI system is only running OSX Mavericks and I was
not able to determine what sort of simulator or IOS device tests were being

Maybe the IOS maintainer and the Continuous Integrator CI maintainer might
allow me to make sense of which combinations of Xcode/OSX/Qt/IOS are best
kept together.

I know the upcoming patch of Qt 5.5.1 for Windows 10 support is a good
pairing, but what is a good XCode to pair with Qt 5.5.1?



On Thu, Jul 30, 2015 at 2:45 PM, mark diener <rpzrpzrpz at gmail.com> wrote:

> Hello List:
> Yosemite 10.10.2 - Xcode 6.1.1  (also on Xcode 6.2) - Qt 5.5.0
> Trying to run on the IOS simulator and get a big fail.  The simulator
> starts up but then the applicaiton output gets
> the following message on a basic project.
> Anybody come across this?
> Debugging starts
> Session could not be started: Unable to run app in Simulator
> Unable to remove simlink at
> `/Users/md/Library/Developer/CoreSimulator/Devices/68424D04-B842-4C71-AE77-6F141822D7E3/data/var/folders/9s/l_fngwkx5rz_fjy85dns7rjw0000gn/T/ios-sim-stderr-pipe-1438292236'
> Unable to remove simlink at
> `/Users/md/Library/Developer/CoreSimulator/Devices/68424D04-B842-4C71-AE77-6F141822D7E3/data/var/folders/9s/l_fngwkx5rz_fjy85dns7rjw0000gn/T/ios-sim-stdout-pipe-1438292236'Run
> ended.Debugging has failed
> Debugging has finished
> Thanks,
> md
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20150730/60597117/attachment.html>

More information about the Interest mailing list